How to control MaxFds?

We’ve got an older EMQX v3.1.1 server that has been chugging along merrily for years but recently bumped into an issue whenever we pass exactly 981 connections.

Looking at the dashboard, I notice that the “MaxFds” is sitting at 1024, which is within the same order of magnitude.

I looked through the various settings suggested by an older tuning guide, but none of those items current values seem to be setting/limiting that MaxFds. How can I increase that limit?

Never mind. I had to adjust the /etc/security/limits.conf and restart the service.

Sorry I missed that.

1 Like