Trying to run address_type hostname but it still seams to be partly running ip based?

Hi I am running two instances of emqx in aws eks to test and i am following the online documentation that recommends using hostname, but when i switch to hostnames it do not seam to work.
Any ide ?

EMQX_RPC__PORT_DISCOVERY [rpc.port_discovery]: manual
EMQX_CLUSTER__K8S__SUFFIX [cluster.k8s.suffix]: svc.cluster.local
EMQX_CLUSTER__K8S__NAMESPACE [cluster.k8s.namespace]: default
EMQX_CLUSTER__K8S__ADDRESS_TYPE [cluster.k8s.address_type]: hostname
EMQX_CLUSTER__K8S__SERVICE_NAME [cluster.k8s.service_name]: emqx-headless
EMQX_CLUSTER__K8S__APISERVER [cluster.k8s.apiserver]: https://kubernetes.default.svc:443
EMQX_NODE__NAME []: emqx@
Listener ssl:default on :8883 started.est3$ k9s
Listener tcp:default is NOT started due to: listener_disabled.
Listener ws:default is NOT started due to: listener_disabled.
Listener wss:default is NOT started due to: listener_disabled.
Listener http:dashboard on :18083 started.
EMQX 5.3.0 is running now!
2023-10-31T08:01:24.703354+00:00 [error] ** Cannot get connection id for node ‘emqx@’

cluster {
name = emqxtest
discovery_strategy = k8s
k8s {
address_type = hostname
namespace = “default”
service_name = “emqx-headless”
suffix = “svc.cluster.local”

I see that the node name is not set to the hostname:
EMQX_NODE__NAME []: emqx@

So EMQX service tries to use the IP address as the node name. Generally, it’s not recommended to use IP addresses in the node names, especially in a highly dynamic environment like Kubernetes.
Can you make sure the configuration parameter is properly configured (i.e. follows emqx@<FQDN-of-the-pod> format)?

How do i do this ? I assumed that EMQX_NAME was used to create this correctly as this is a template. If i set EMQX_NODE__NAME=emqx.default.svc.cluster.local will that not be the same on all my instances then ?

Trying this:
Building K8S cluster of EMQX starting from scratch | EMQ

Upgraded to 3.5.1 and added env now it seams to work.

    - name: EMQX_NAME
      value: emqx
      value: k8s
      value: https://kubernetes.default.svc:443
      value: default
      value: emqx-headless
      value: hostname
      value: svc.cluster.local